provideWidgets Method
UiItemsManager calls following method to augment Widget lists.
provideWidgets(stageId: string, stageUsage: string, location: StagePanelLocation, section?: StagePanelSection, _zoneLocation?: AbstractZoneLocation, stageAppData?: any): ReadonlyArray<AbstractWidgetProps>
@note Returned widgets must provide unique AbstractWidgetProps["id"]
to correctly save/restore App layout.
Parameter | Type | Description |
---|---|---|
stageId | string | |
stageUsage | string | |
location | StagePanelLocation | |
section | StagePanelSection | |
_zoneLocation | AbstractZoneLocation | |
stageAppData | any |
Returns - ReadonlyArray<AbstractWidgetProps>
Defined in
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.