GraphicsDriverBugs Interface
Known bugs associated with specific graphics drivers for which iTwin.js can apply workarounds to produce correct visualization. An instance of this object will exist on the WebGLRenderCompatibilityInfo object returned by queryRenderCompatibility.
@see WebGLRenderCompatibilityInfo
Properties
Name | Type | Description | |
---|---|---|---|
fragDepthDoesNotDisableEarlyZ | "true" | undefined | If true, the graphics driver inappropriately applies the "early Z" optimization when a fragment shader writes to the depth buffer. | |
msaaWillHang | "true" | undefined | If true, the graphics driver will hang when applying MSAA to a viewport. |
Defined in
- RenderCompatibility.ts Line 82
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.