SelectionScopesManagerProps Interface
Deprecated in 5.0. Use computeSelection
from @itwin/unified-selection package instead.
Properties for creating SelectionScopesManager.
Properties
Name | Type | Description | |
---|---|---|---|
localeProvider | () => undefined | string | undefined | Provider of active locale to use for localizing scopes | |
rpcRequestsHandler | { computeSelection: (args: ComputeSelectionRequestOptions<IModelRpcProps> & ClientDiagnosticsAttribute) => Promise<KeySetJSON>, getSelectionScopes: (args: SelectionScopeRequestOptions<IModelRpcProps> & ClientDiagnosticsAttribute) => Promise<SelectionScope[]> } | RPC handler to use for requesting selection scopes |
Defined in
Last Updated: 03 April, 2025
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.