computeSelection Method

Computes keys that need to be added to logical selection based on provided selection scope.

computeSelection(imodel: IModelConnection, ids: Id64Arg, scope: string | SelectionScope | SelectionScopeProps): Promise<KeySet>

Parameter Type Description
imodel IModelConnection  
ids Id64Arg Element IDs to compute selection for
scope string | SelectionScope | SelectionScopeProps Selection scope to apply

Returns - Promise<KeySet>

Defined in

Last Updated: 04 April, 2025