SelectionManagerProps Interface
Deprecated in 5.0. Use SelectionStorage
from @itwin/unified-selection package instead.
Properties for creating SelectionManager.
Properties
Name | Type | Description | |
---|---|---|---|
imodelKeyFactory | (imodel: IModelConnection) => string | undefined | An optional function that returns a key for the given iModel. | |
scopes | SelectionScopesManager | A manager for selection scopes | |
selectionStorage | SelectionStorage | undefined | Custom unified selection storage to be used by SelectionManager. |
Defined in
Last Updated: 03 April, 2025
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.