getSelection Method
Get the selection currently stored in this manager
getSelection(imodel: IModelConnection, level: number0): Readonly<KeySet>
@note Calling immediately after add*
|replace*
|remove*
|clear*
method call does not guarantee
that returned KeySet
will include latest changes. Listen for selectionChange
event to get the
latest selection after changes.
Parameter | Type | Description |
---|---|---|
imodel | IModelConnection | |
level | number |
Returns - Readonly<KeySet>
Defined in
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.