usePresentationTable Function
Custom hook that loads data for generic table component.
usePresentationTable<TColumn, TRow>(props: UsePresentationTableProps<TColumn, TRow>): UsePresentationTableResult<TColumn, TRow>
@throws on failure to get table data. The error is thrown in the React's render loop, so it can be caught using an error boundary.
Parameter | Type | Description |
---|---|---|
props | UsePresentationTableProps<TColumn, TRow> |
Returns - UsePresentationTableResult<TColumn, TRow>
Defined in
Last Updated: 15 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.