PresentationInstanceFilterBuilderProps Interface
Props for PresentationInstanceFilterBuilder component.
Properties
Name | Type | Description | |
---|---|---|---|
descriptor | Descriptor | Descriptor containing properties and classes that should be available for building filter. | |
imodel | IModelConnection | iModel connection to pull data from. | |
initialFilter | PresentationInstanceFilterInfo | undefined | Initial filter that will be show when component is mounted. | |
onInstanceFilterChanged | (filter?: PresentationInstanceFilterInfo) => void | Callback that is invoked when filter changes. | |
ruleGroupDepthLimit | number | undefined | Specifies how deep rule groups can be nested. | Deprecated |
Defined in
Last Updated: 15 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.