PropertyGroup Interface
Property grouping allows grouping by a property of the instance by value or by given ranges of values.
@see Property grouping documentation section
Extends
Properties
Name | Type | Description | |
---|---|---|---|
createGroupForSingleItem | boolean | undefined | Specifies whether a grouping node should be created if there is only one item in that group. | |
createGroupForUnspecifiedValues | boolean | undefined | Should a separate grouping node be created for nodes whose grouping value is not set or is set to an empty string. | |
imageId | string | undefined | Specifies grouping node's image ID. | Deprecated |
propertyName | string | Name of the ECProperty which is used for grouping. | |
ranges | PropertyRangeGroupSpecification[] | undefined | Ranges into which the grouping values are divided. | |
specType | "Property" | Used for serializing to JSON. |
Defined in
Last Updated: 21 February, 2025
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.