PropertyCategorySpecification Interface
Content modifier for defining custom property categories. Custom categories are not present in the result unless they contain at least one property. One way to assign a property to the category is by using property overrides.
@see Property category specification reference documentation page
Properties
Name | Type | Description | |
---|---|---|---|
autoExpand | boolean | undefined | Controls the value of CategoryDescription.expand which tells the UI component | |
description | string | undefined | Extensive description of the category. | |
id | string | Category identifier used to reference the category definition from property overrides or other category | |
label | string | Display label of the category. | |
parentId | string | NoCategoryIdentifier | CategoryIdentifier | Identifier of a parent category. | |
priority | number | undefined | Assign a custom priority to the category. | |
renderer | CustomRendererSpecification | undefined | Custom category renderer specification that allows |
Defined in
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.