constructor Method
PropertiesField(props)
Creates an instance of PropertiesField.
PropertiesField(props: PropertiesFieldProps): PropertiesField
Parameter | Type | Description |
---|---|---|
props | PropertiesFieldProps |
Returns - PropertiesField
PropertiesField(category, name, label, type, isReadonly, priority, properties, editor?, renderer?)
Deprecated in 5.0. Use an overload with PropertiesFieldProps
instead.
Creates an instance of PropertiesField.
PropertiesField(category: CategoryDescription, name: string, label: string, type: TypeDescription, isReadonly: boolean, priority: number, properties: Property[], editor?: EditorDescription, renderer?: RendererDescription): PropertiesField
Parameter | Type | Description |
---|---|---|
category | CategoryDescription | Category information |
name | string | Unique name |
label | string | Display label |
type | TypeDescription | Description of this field's values data type |
isReadonly | boolean | Are values in this field read-only |
priority | number | Priority of the field |
properties | Property[] | A list of properties this field is created from |
editor | EditorDescription | Property editor used to edit values of this field |
renderer | RendererDescription | Property renderer used to render values of this field |
Returns - PropertiesField
Defined in
Last Updated: 21 February, 2025
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.