NestedContentValue Interface

Data structure that describes nested content value.

Properties

Name Type Description
displayValues ValuesDictionary<DisplayValue> Content display values map  
label LabelDefinition | undefined    
labelDefinition LabelDefinition | undefined Label of the ECInstance that this NestedContentValue is based on. Deprecated  
mergedFieldNames string[] Names of fields whose values are merged  
primaryKeys InstanceKey[] Keys of instances whose content is contained in this value  
values ValuesDictionary<Value> Content values map  

Defined in

Last Updated: 21 February, 2025