NestedContentFieldJSON<TClassInfoJSON> Interface
Data structure for a NestedContentField serialized to JSON.
Extends
Properties
Name | Type | Description | |
---|---|---|---|
actualPrimaryClassIds | string[] | undefined | ||
autoExpand | boolean | undefined | ||
contentClassInfo | TClassInfoJSON | ||
nestedFields | FieldJSON<TClassInfoJSON>[] | ||
pathToPrimaryClass | RelationshipPathJSON<TClassInfoJSON> | ||
relationshipMeaning | RelationshipMeaning | undefined |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
category Inherited | string | BaseFieldJSON | |
editor Inherited | EditorDescription | undefined | BaseFieldJSON | |
extendedData Inherited | { T } | undefined | BaseFieldJSON | |
isReadonly Inherited | boolean | BaseFieldJSON | |
label Inherited | string | BaseFieldJSON | |
name Inherited | string | BaseFieldJSON | |
priority Inherited | number | BaseFieldJSON | |
renderer Inherited | RendererDescription | undefined | BaseFieldJSON | |
type Inherited | TypeDescription | BaseFieldJSON |
Defined in
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.