constructor Method
Field(props)
Creates an instance of Field.
Field(props: FieldProps): Field
Parameter | Type | Description |
---|---|---|
props | FieldProps |
Returns - Field
Field(category, name, label, type, isReadonly, priority, editor?, renderer?, extendedData?)
Deprecated in 5.0. Use an overload with FieldProps
instead.
Creates an instance of Field.
Field(category: CategoryDescription, name: string, label: string, type: TypeDescription, isReadonly: boolean, priority: number, editor?: EditorDescription, renderer?: RendererDescription, extendedData?: [key: string]: unknown): Field
Parameter | Type | Description |
---|---|---|
category | CategoryDescription | Category information |
name | string | Unique name |
label | string | Display label |
type | TypeDescription | Description of this field's values data type |
isReadonly | boolean | Are values in this field read-only |
priority | number | Priority of the field |
editor | EditorDescription | Property editor used to edit values of this field |
renderer | RendererDescription | Property renderer used to render values of this field |
extendedData | [key: string]: unknown | Extended data associated with this field |
Returns - Field
Defined in
Last Updated: 21 February, 2025
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.