getContentSources Method
Get information about the sources of content when building it for specific ECClasses. Sources involve classes of the primary select instance, its related instances for loading related and navigation properties.
getContentSources(requestOptions: ContentSourcesRequestOptions<IModelDb> & { priority?: number } & { cancelEvent?: BeEvent<() => void> } & BackendDiagnosticsAttribute): Promise<SelectClassInfo[]>
Parameter | Type | Description |
---|---|---|
requestOptions | ContentSourcesRequestOptions<IModelDb> & { priority?: number } & { cancelEvent?: BeEvent<() => void> } & BackendDiagnosticsAttribute |
Returns - Promise<SelectClassInfo[]>
Defined in
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.