GoogleMapsCreateSessionOptions Interface

Represents the options to create a Google Maps session.

Properties

Name Type Description
apiOptions string[] | undefined An array of values specifying additional options to apply.  
language string An [[IETF language tag]] that specifies the language used to display information on the tiles.  
layerTypes GoogleMapsLayerTypes[] | undefined An array of values that specifies the layer types added to the map.  
mapType GoogleMapsMapTypes The type of base map.  
overlay boolean | undefined A boolean value that specifies whether layerTypes should be rendered as a separate overlay, or combined with the base imagery.  
region string A [[Common Locale Data Repository]] region identifier (two uppercase letters) that represents the physical location of the user.  
scale GoogleMapsScaleFactors | undefined Scales-up the size of map elements (such as road labels), while retaining the tile size and coverage area of the default tile.  

Defined in

Last Updated: 26 April, 2025