LinearlyLocatedAttributionProps Interface

Properties of a LinearlyLocatedAttribution

Extends

Inherited properties

Name Type Inherited from Description
attributedElement Inherited RelatedElementProps | undefined ILinearlyLocatedAttributionProps  
category Inherited string GeometricElement3dProps The id of the category for this geometric element.
classFullName Inherited string GeometricElement3dProps The full name of the ECClass for this entity, in the form "Schema:ClassName"
code Inherited CodeProps GeometricElement3dProps The Code for this element
elementGeometryBuilderParams Inherited ElementGeometryBuilderParams | undefined GeometricElement3dProps Describes how to build the element's GeometryStream, as an alternative to GeometricElement3dProps.geom.
federationGuid Inherited string | undefined GeometricElement3dProps A FederationGuid assigned to this element.
geom Inherited GeometryStreamProps | undefined GeometricElement3dProps The geometry stream properties
id Inherited string | undefined GeometricElement3dProps The Id of the entity.
isInstanceOfEntity Readonly Inherited undefined | undefined GeometricElement3dProps A non-existent property used to discriminate between EntityProps and Entity.
jsonProperties Inherited any | undefined GeometricElement3dProps Optional json properties of this element.
model Inherited string GeometricElement3dProps The Id of the Model containing this element
parent Inherited RelatedElementProps | undefined GeometricElement3dProps The Parent of this element, if defined.
placement Inherited Placement3dProps | undefined GeometricElement3dProps The placement properties
typeDefinition Inherited RelatedElementProps | undefined GeometricElement3dProps  
userLabel Inherited string | undefined GeometricElement3dProps A user-assigned label for this element.

Defined in

Last Updated: 21 November, 2024