WeightPickerProps Interface
Properties for the WeightPickerButton React component
Extends
- React.ButtonHTMLAttributes<HTMLButtonElement>
- CommonProps
Properties
Name | Type | Description | |
---|---|---|---|
activeWeight | number | active weight | |
colorDef | ColorDef | undefined | color specification | |
disabled | boolean | undefined | Disabled or not | |
dropDownTitle | string | undefined | Title to show at top of DropDown | |
hideLabel | boolean | undefined | hide the weight label | |
onLineWeightPick | (weight: number) => void | undefined | function to run when user selects weight swatch | |
readonly | boolean | undefined | Readonly or not | |
weights | number[] | available weights |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
itemId | string | undefined | CommonProps | Optional unique identifier for item. |
Defined in
Last Updated: 20 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.