LineWeightSwatchProps Interface
Properties for the LineWeightSwatch React component
Extends
- React.ButtonHTMLAttributes<HTMLButtonElement>
- CommonProps
Properties
Name | Type | Description | |
---|---|---|---|
colorDef | ColorDef | undefined | color specification | |
disabled | boolean | undefined | Disabled or not | |
hideLabel | boolean | undefined | hide the weight label | |
onClick | () => void | undefined | function to run when user selects a line weight swatch | |
readonly | boolean | undefined | Readonly or not | |
weight | number | color specification |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
itemId | string | undefined | CommonProps | Optional unique identifier for item. |
Defined in
Last Updated: 20 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.