KeyinFieldProps Interface
Properties controlling how a KeyinField is created.
Properties
Name | Type | Description | |
---|---|---|---|
baseId | string | Required, unique ID prefix used to produce unique IDs for child elements. | |
historyLength | number | undefined | The maximum number of submitted key-ins to store in the history. | |
localization | KeyinFieldLocalization | undefined | Controls whether localized and/or non-localized keyin strings appear in the autocompletion list. | |
parent | HTMLElement | undefined | If supplied, the keyin field's elements will be added as children of this parent element. | |
wantButton | boolean | undefined | Default: false. | |
wantLabel | boolean | undefined | Default: false. |
Defined in
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.