EditorIpc Interface
Interface called from frontend EditTool
s to start and drive the active EditCommand
on the backend.
Properties
Name | Type | Description | |
---|---|---|---|
callMethod | (name: string, ...args: any[]) => Promise<any> | Call a method on the currently active EditCommand and return its value. |
|
startCommand | (commandId: string, iModelKey: string, ...args: any[]) => Promise<any> | Start a new instance of an EditCommand on the backend, and then call its onStart method. |
Defined in
- EditorIpc.ts Line 19
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.