updateGeometricElement Method
Update an existing geometric element.
updateGeometricElement(propsOrId: string | GeometricElementProps, data?: ElementGeometryBuilderParams): Promise<void>
@see GeometryStream, ElementGeometry
@throws IModelError if unable to update the element
Parameter | Type | Description |
---|---|---|
propsOrId | string | GeometricElementProps | Properties or element id to update for an existing GeometricElement |
data | ElementGeometryBuilderParams | Optional binary format GeometryStream representation used in lieu of GeometricElementProps.geom or GeometricElementProps.elementGeometryBuilderParams. |
Returns - Promise
Defined in
- EditBuiltInCommand.ts Line 97
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.