updateEcefLocation Method
Update the position of the iModel on the earth.
updateEcefLocation(ecefLocation: EcefLocationProps): Promise<void>
@throws IModelError if unable to aquire schema lock or update the ecef location property.
@note Clears the geographic coordinate reference system of the iModel, do not call when a valid GCS exists.
Parameter | Type | Description |
---|---|---|
ecefLocation | EcefLocationProps | New ecef location properties. |
Returns - Promise
Defined in
- EditBuiltInCommand.ts Line 217
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.