requestElementGeometry Method
Request geometry from an existing element. Because a GeometryStream can be large and may contain information that is not always useful to frontend code, filter options are provided to restrict what GeometryStreams are returned. For example, a tool may only be interested in a GeometryStream that stores a single CurveCollection.
requestElementGeometry(elementId: string, filter?: FlatBufferGeometryFilter): Promise<undefined | ElementGeometryInfo>
@see GeometryStream, ElementGeometry
@throws IModelError if unable to query the element
Parameter | Type | Description |
---|---|---|
elementId | string | |
filter | FlatBufferGeometryFilter | Optional criteria for accepting a GeometryStream. |
Returns - Promise<undefined | ElementGeometryInfo>
Defined in
- EditBuiltInCommand.ts Line 118
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.