getFormat Method
Retrieves a Format from a SchemaContext. If the format is part of a KindOfQuantity, the first presentation format in the KindOfQuantity that matches the current unit system will be retrieved. If no presentation format matches the current unit system, the persistence unit format will be retrieved if it matches the current unit system. Else, the default presentation format will be retrieved.
getFormat(name: string): Promise<undefined | SchemaItemFormatProps>
Parameter | Type | Description |
---|---|---|
name | string | The full name of the Format or KindOfQuantity. |
Returns - Promise<undefined | SchemaItemFormatProps>
Defined in
Last Updated: 26 April, 2025
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.