parseSchemaItemType Function
Tries to parse the given string as one of the 8 schema item types.
parseSchemaItemType(type: string): SchemaItemType | undefined
@returns A valid SchemaItemType if successfully parsed. Otherwise, undefined if the provided string is not a valid SchemaItemType.
Parameter | Type | Description |
---|---|---|
type | string | The schema item type string to parse. |
Returns - SchemaItemType | undefined
A valid SchemaItemType if successfully parsed. Otherwise, undefined if the provided string is not a valid SchemaItemType.
Defined in
- ecschema-metadata/src/ECObjects.ts Line 165
Last Updated: 23 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.