parsePrimitiveType Function
Tries to parse the given string as one of the 10 primitive types.
parsePrimitiveType(type: string): PrimitiveType | undefined
@returns A valid PrimitiveType if successfully parsed, or undefined if the provided string is not a valid PrimitiveType.
Parameter | Type | Description |
---|---|---|
type | string | The primitive type string to parse. |
Returns - PrimitiveType | undefined
A valid PrimitiveType if successfully parsed, or undefined if the provided string is not a valid PrimitiveType.
Defined in
- ecschema-metadata/src/ECObjects.ts Line 223
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.