encode MethodStatic

Create an ECName from an arbitrary string, encoding any special characters as "x####" where "####" is the UTF-16 character code.

encode(input: string): ECName

@throws ECSchemaError if input is an empty string.

Parameter Type Description
input string  

Returns - ECName

Defined in

Last Updated: 26 April, 2025