getSchema Method

Attempts to obtain a schema from this context that matches the specified criteria.

getSchema(schemaKey: Readonly<SchemaKey>, matchType: SchemaMatchTypeSchemaMatchType.Latest): Promise<undefined | Schema>

@returns the schema matching the input criteria, or undefined if no such schema could be located.

Parameter Type Description
schemaKey Readonly<SchemaKey> Identifies the schema to obtain.
matchType SchemaMatchType Criteria by which to identify potentially matching schemas.

Returns - Promise<undefined | Schema>

the schema matching the input criteria, or undefined if no such schema could be located.

Defined in

Last Updated: 21 February, 2025