getSchemaSync Method
Attempts to get a schema from the locater. Yields undefined if no matching schema is found. For schemas that may have references, construct and call through a SchemaContext instead.
getSchemaSync(schemaKey: Readonly<SchemaKey>, matchType: SchemaMatchType, context: SchemaContext): undefined | Schema
Parameter | Type | Description |
---|---|---|
schemaKey | Readonly<SchemaKey> | key to look up |
matchType | SchemaMatchType | how to match key against candidate schemas |
context | SchemaContext | context for loading schema references |
Returns - undefined | Schema
Defined in
- ecschema-metadata/src/Context.ts Line 60
Last Updated: 21 February, 2025
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.