getSchema Method

Attempts to retrieve a Schema with the given SchemaKey by searching the configured Schema strings.

getSchema(schemaKey: SchemaKey, matchType: SchemaMatchType, context: SchemaContext): Promise<undefined | Schema>

Parameter Type Description
schemaKey SchemaKey  
matchType SchemaMatchType The SchemaMatchType.
context SchemaContext The SchemaContext that will control the lifetime of the schema and holds the schema's references, if they exist.

Returns - Promise<undefined | Schema>

Defined in

Last Updated: 21 February, 2025