getSchemaSync Method

Attempts to retrieve a Schema with the given SchemaKey by using the configured search paths to locate the XML Schema file from the file system.

getSchemaSync(key: SchemaKey, matchType: SchemaMatchType, context: SchemaContext): undefined | Schema

Parameter Type Description
key SchemaKey The SchemaKey of the Schema to retrieve.
matchType SchemaMatchType The SchemaMatchType.
context SchemaContext The SchemaContext that will control the lifetime of the schema.

Returns - undefined | Schema

Defined in

Last Updated: 21 February, 2025