getSchemaSync Method

Attempts to retrieve a Schema with the given SchemaKey by using the configured search paths to locate the JSON schema file from the file system.

getSchemaSync<T extends Schema>(schemaKey: SchemaKey, matchType: SchemaMatchType, context: SchemaContext): undefined | T

Parameter Type Description
schemaKey SchemaKey  
matchType SchemaMatchType The SchemaMatchType
context SchemaContext The SchemaContext that will control the lifetime of the schema.

Returns - undefined | T

Defined in

Last Updated: 23 November, 2024