getSchema MethodAbstract
Attempts to retrieve a Schema with the given SchemaKey by using the configured search paths to locate the XML Schema file from the file system. Returns only Schemas from XML files with their keys populated.
getSchema(key: SchemaKey, matchType: SchemaMatchType, context: SchemaContext): Promise<undefined | Schema>
Parameter | Type | Description |
---|---|---|
key | SchemaKey | The SchemaKey of the Schema to retrieve. |
matchType | SchemaMatchType | The SchemaMatchType. |
context | SchemaContext | The SchemaContext that will control the lifetime of the schema. |
Returns - Promise<undefined | Schema>
Defined in
Last Updated: 04 April, 2025
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.