constructor Method
Initializes a new FormatDiagnosticReporter
LoggingDiagnosticReporter(suppressions?: Map<string, string[]>, localization?: Localization): LoggingDiagnosticReporter
Parameter | Type | Description |
---|---|---|
suppressions | Map<string, string[]> | A Map where the key is a schema full name and the value is collection of diagnostic codes to suppress. |
localization | Localization | The Localization instance to use to translate validation messages. |
Returns - LoggingDiagnosticReporter
Defined in
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.