ResizableContainerObserver Function
Deprecated in 4.15.0. Please use third party packages.
ResizableContainerObserver is a component that provides the functionality similar to the ReactResizeDetector option that call a function when the observed element is resized. This implementation properly handles observing element in pop-out/child windows. If children nodes are defined then the div added by the component is considered the container whose size will be observed. If no children are provided then the component will report size changes from its parent container.
ResizableContainerObserver(__namedParameters: { children?: React.ReactNode, onResize: (width: number, height: number) => void }): React.JSX.Element
Parameter | Type | Description |
---|---|---|
__namedParameters | { children?: React.ReactNode, onResize: (width: number, height: number) => void } |
Returns - React.JSX.Element
Defined in
Last Updated: 20 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.