TabLabel Interface

Deprecated  in 4.12.0. Interface used in a deprecated component Tabs.

TabLabel provides ability to define label, icon, and tooltip for a tab entry. The tooltip can be defined as JSX|Element to support react-tooltip component or a string that will be use to set the title property.

Properties

Name Type Description
disabled boolean | undefined    
icon string | React.ReactElement<any, string | React.JSXElementConstructor<any>>    
label string    
subLabel string | undefined    
tabId string    
tooltip string | React.ReactElement<any, string | React.JSXElementConstructor<any>> tooltip allows React.ReactElement to support styled tooltips like react-tooltip.  

Defined in

Last Updated: 20 November, 2024