LoadingPromptProps Interface
Deprecated in 4.12.0. Props of deprecated component LoadingPrompt.
Properties for LoadingPrompt component
Extends
Properties
Name | Type | Description | |
---|---|---|---|
isDeterminate | boolean | Determine if a percentage bar is displayed (isDeterminate=true), otherwise a loading spinner or indeterminate progress bar is shown. | |
string | undefined | Message displayed below the title (optional) | ||
onCancel | () => void | undefined | Function called when Cancel button is clicked. | |
percent | number | Current percentage. | |
showCancel | boolean | Show cancel button. | |
showIndeterminateBar | boolean | Show indeterminate progress bar instead of loading spinner | |
showPercentage | boolean | Show percentage at the end of the loading bar (optional). | |
showStatus | boolean | Show current status and percentage. | |
status | string | Current loading status text (optional). | |
title | string | Title |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
className | string | undefined | CommonProps | Custom CSS class name |
itemId | string | undefined | CommonProps | Optional unique identifier for item. |
style | React.CSSProperties | undefined | CommonProps | Custom CSS style properties |
Defined in
Last Updated: 20 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.