WebFontIconProps Interface

Deprecated  in 4.15.0. Props of deprecated WebFontIcon component.

Properties for the WebFontIcon React component

Extends

Properties

Name Type Description
iconClassName string | undefined Class name of icon used for custom font-family icons  
iconName string Bentley Web Font icon name  
iconSize "small" | "medium" | "large" | "x-large" | "x-small" Size of the icon  
onClick React.MouseEventHandler<HTMLSpanElement> | undefined Click event handler  
title string | undefined Text that will be shown when hovered on the icon.  

Inherited properties

Name Type Inherited from Description
className string | undefined CommonProps Custom CSS class name
itemId string | undefined CommonProps Optional unique identifier for item.
style React.CSSProperties | undefined CommonProps Custom CSS style properties

Defined in

Last Updated: 20 November, 2024