constructor Method

Constructor for ConditionalIconItem

ConditionalIconItem(iconGetter: () => IconSpec, syncEventIds: string[], value?: IconSpec): ConditionalIconItem

Parameter Type Description
iconGetter () => IconSpec Function to retrieve the icon that matches the condition. Returns an IconSpec.
syncEventIds string[] The array of event ids to be monitored. These events are triggered when the condition(s) that control the icon change.
value IconSpec The default IconSpec. If this is not specified, the function is run to get the initial value.

Returns - ConditionalIconItem

Defined in

Last Updated: 21 November, 2024