ElementSeparatorProps Interface
Deprecated in 4.12.0. Props of deprecated component ElementSeparator.
Properties of ElementSeparator React component
Extends
Properties
Name | Type | Description | |
---|---|---|---|
isResizeHandleBeingDragged | boolean | undefined | Is resize handle being dragged | |
isResizeHandleHovered | boolean | undefined | Is resize handle hovered | |
movableArea | number | undefined | Area width or height (depending on orientation) in pixels | |
onRatioChanged | (ratio: number) => void | RatioChangeResult | undefined | Callback to ratio changed event | |
onResizeHandleDragChanged | (isDragStarted: boolean) => void | undefined | Callback to drag event change | |
onResizeHandleHoverChanged | (isHovered: boolean) => void | undefined | Callback to hover event change | |
orientation | Orientation | Separator orientation | |
ratio | number | Ratio between left cell and right cell | |
separatorSize | number | undefined | Separator width or height in pixels. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
className | string | undefined | CommonProps | Custom CSS class name |
itemId | string | undefined | CommonProps | Optional unique identifier for item. |
style | React.CSSProperties | undefined | CommonProps | Custom CSS style properties |
Defined in
Last Updated: 20 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.