PopupContextMenuProps Interface
Deprecated in 4.16.0. Props of deprecated PopupContextMenu component.
Properties for PopupContextMenu component
Extends
Properties
Name | Type | Description | |
---|---|---|---|
animate | boolean | undefined | Indicates whether to use animation for open/close (defaults to true) | |
ariaLabel | string | undefined | accessibility label | |
autoflip | boolean | undefined | Whether menu flips directions based on screen edge. | |
children | React.ReactNode | undefined | ContextMenu items | |
edgeLimit | boolean | undefined | Whether menu hugs screen edge when autoflip is off. | |
hotkeySelect | boolean | undefined | Whether Hotkey press selects item, or just highlights item. | |
isOpen | boolean | Indicates whether the popup is shown or not (defaults to false) | |
left | number | undefined | Left position (absolute positioning - defaults to 0) | |
offset | number | undefined | Offset from the parent (defaults to 4) | |
onClose | () => void | undefined | Function called when the popup is closed | |
onEnter | () => void | undefined | Function called when the popup is closed on Enter | |
onEsc | (event: React.KeyboardEvent<Element>) => void | undefined | when Escape button is pressed | |
onOpen | () => void | undefined | Function called when the popup is opened | |
onOutsideClick | (e: MouseEvent) => void | undefined | Function called when user clicks outside the popup | |
onSelect | (event: React.MouseEvent<Element, MouseEvent>) => void | undefined | When list item or submenu is selected | |
position | RelativePosition | undefined | Direction (relative to the target) to which the popup is expanded (defaults to Bottom) | |
selectedIndex | number | undefined | starting menu item selected index Default: -1 | |
target | "null" | HTMLElement | Target element to position popup | |
top | number | undefined | Top position (absolute positioning - defaults to 0) |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
className | string | undefined | CommonProps | Custom CSS class name |
itemId | string | undefined | CommonProps | Optional unique identifier for item. |
style | React.CSSProperties | undefined | CommonProps | Custom CSS style properties |
Defined in
Last Updated: 20 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.