ImageCheckBoxProps Interface
Deprecated in 4.12.0. Props of deprecated component ImageCheckBox.
Properties for the ImageCheckBox component
Extends
Properties
Name |
Type |
Description |
|
border |
boolean | undefined |
If true, draw a border around the image checkbox |
|
checked |
boolean | undefined |
Determine if the item is checked or not |
|
disabled |
boolean | undefined |
Determine if the item is disabled or not |
|
imageOff |
React.ReactNode |
Image for the "unchecked" (default) state |
|
imageOn |
React.ReactNode |
Image for the "checked" state |
|
inputClassName |
string | undefined |
Custom CSS class name for the checkbox input element |
|
inputRef |
React.Ref<HTMLInputElement> | undefined |
Provides ability to return reference to HTMLInputElement |
|
inputStyle |
React.CSSProperties | undefined |
Custom CSS Style for the checkbox input element |
|
onClick |
(checked: boolean) => any | undefined |
Function called when item is clicked. |
|
tooltip |
string | undefined |
Tooltip to be displayed when mouse is hovered over the checkbox |
|
Inherited properties
Name |
Type |
Inherited from |
Description |
className Inherited |
string | undefined |
CommonProps |
Custom CSS class name |
itemId Inherited |
string | undefined |
CommonProps |
Optional unique identifier for item. |
style Inherited |
React.CSSProperties | undefined |
CommonProps |
Custom CSS style properties |
Defined in
Last Updated: 30 January, 2025