AutoSuggestProps Interface

Deprecated  in 4.16.0. Props of deprecated AutoSuggest component.

Properties for the AutoSuggest component.

Extends

  • React.InputHTMLAttributes<HTMLInputElement>
  • CommonProps

Properties

Name Type Description
getLabel (value: string) => string | undefined Gets a label associated with a given value  
getSuggestions AsyncGetAutoSuggestDataFunc | undefined Asynchronously calculate suggestions for any given input value.  
onInputFocus (e: React.FocusEvent<HTMLInputElement, Element>) => void | undefined Handler for input receiving focus.  
onPressEnter (e: React.KeyboardEvent<HTMLInputElement>) => void | undefined Handler for Enter key.  
onPressEscape (e: React.KeyboardEvent<HTMLInputElement>) => void | undefined Handler for Escape key.  
onPressTab (e: React.KeyboardEvent<HTMLInputElement>) => void | undefined Handler for Tab key.  
onSuggestionSelected (selected: AutoSuggestData) => void Handler for when suggested selected.  
onSuggestionsClearRequested () => void | undefined Called every time you need to clear suggestions.  
options AutoSuggestData[] | GetAutoSuggestDataFunc Options for dropdown.  
setFocus boolean | undefined Indicates whether to set focus to the input element  
value string | undefined Optional input value override.  

Inherited properties

Name Type Inherited from Description
itemId string | undefined CommonProps Optional unique identifier for item.

Defined in

Last Updated: 20 November, 2024