triangulateGreedyEarCut MethodStatic
"Triangulate" by cutting of the ear with best aspect ratio. Reject if successive normals have negative dot product with PolygonOps.AreaNormal
triangulateGreedyEarCut(points: Point3d[], announceLoopAndTriangles: AnnounceLoopAndTrianglesFunction): boolean
Parameter | Type | Description |
---|---|---|
points | Point3d[] | |
announceLoopAndTriangles | AnnounceLoopAndTrianglesFunction |
Returns - boolean
Defined in
- topology/SpaceTriangulation.ts Line 55
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.