strokeConstantVSection Method
Return strokes for the elliptical arc cross-section at latitude sweep fraction v.
- Optional inputs control the number of strokes along the cross-section:
- If
fixedStrokeCount
is supplied, it is taken as the cross-section stroke count. - If
fixedStrokeCount
is undefined, stroke count is computed by applyingoptions
to the cross-section. - If neither input is supplied, the stroke count default is 16.
- In any case, stroke count is clamped to the interval [4,64].
- If
strokeConstantVSection(v: number, fixedStrokeCount?: number, options?: StrokeOptions): LineString3d
@returns strokes as line string
Parameter | Type | Description |
---|---|---|
v | number | fractional position along the sphere axis |
fixedStrokeCount | number | optional stroke count in u-direction |
options | StrokeOptions | optional stroke options in u-direction |
Returns - LineString3d
strokes as line string
Defined in
- solid/Sphere.ts Line 176
Last Updated: 18 January, 2025
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.