createFromAxesAndScales MethodStatic
Create a sphere.
- If
axes
is supplied, its columns are scaled by the radii to form the sphere's local frame.
createFromAxesAndScales(center: Point3d, axes: Matrix3d, radiusX: number, radiusY: number, radiusZ: number, latitudeSweep?: AngleSweep, capped?: boolean): undefined | Sphere
Parameter | Type | Description |
---|---|---|
center | Point3d | |
axes | Matrix3d | |
radiusX | number | |
radiusY | number | |
radiusZ | number | |
latitudeSweep | AngleSweep | |
capped | boolean |
Returns - undefined | Sphere
Defined in
- solid/Sphere.ts Line 123
Last Updated: 03 April, 2025
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.