createDgnSphere MethodStatic
Create a sphere from the typical parameters of the DGN file.
- This method normalizes the input vectors, squares
vectorX
againstvectorZ
, and scales the radii by the vectors' original lengths. - These restrictions allow the sphere to be represented by an element in the DGN file.
createDgnSphere(center: Point3d, vectorX: Vector3d, vectorZ: Vector3d, radiusXY: number, radiusZ: number, latitudeSweep?: AngleSweep, capped?: boolean): undefined | Sphere
Parameter | Type | Description |
---|---|---|
center | Point3d | |
vectorX | Vector3d | |
vectorZ | Vector3d | |
radiusXY | number | |
radiusZ | number | |
latitudeSweep | AngleSweep | |
capped | boolean |
Returns - undefined | Sphere
Defined in
- solid/Sphere.ts Line 108
Last Updated: 03 April, 2025
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.