createDgnCone MethodStatic
Create a circular cone from the typical parameters of the DGN file.
- This method calls createBaseAndTarget with normalized vectors,
vectorY
squared againstvectorX
, andradiusA
andradiusB
scaled by the original length ofvectorX
. - These restrictions allow the cone to be represented by an element in the DGN file.
createDgnCone(centerA: Point3d, centerB: Point3d, vectorX: Vector3d, vectorY: Vector3d, radiusA: number, radiusB: number, capped?: boolean): undefined | Cone
Parameter | Type | Description |
---|---|---|
centerA | Point3d | |
centerB | Point3d | |
vectorX | Vector3d | |
vectorY | Vector3d | |
radiusA | number | |
radiusB | number | |
capped | boolean |
Returns - undefined | Cone
Defined in
- solid/Cone.ts Line 136
Last Updated: 03 April, 2025
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.