createBaseAndTarget MethodStatic
Create a general cone from cross sections parallel to the plane spanned by the given vectors.
- Circular cross sections are indicated by perpendicular vectors of the same length.
- Elliptical cross sections are indicated by non-perpendicular vectors, or vectors of different lengths.
- Cross sectional planes do not have to be perpendicular to the axis line between centers.
- Cross section size is affected both by the given vector lengths and radii. To avoid unexpected scaling, pass orthonormal vectors for circular cross sections, or unit radii for elliptical cross sections.
- There is no validation of the input radii. For best results, they should be nonnegative, and at least one should be nonzero.
createBaseAndTarget(centerA: Point3d, centerB: Point3d, vectorX: Vector3d, vectorY: Vector3d, radiusA: number, radiusB: number, capped?: boolean): Cone
Parameter | Type | Description |
---|---|---|
centerA | Point3d | |
centerB | Point3d | |
vectorX | Vector3d | |
vectorY | Vector3d | |
radiusA | number | |
radiusB | number | |
capped | boolean |
Returns - Cone
Defined in
- solid/Cone.ts Line 122
Last Updated: 03 April, 2025
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.